Paginas em branco oriundas do Proxy Squid?

Paginas em branco oriundas do Proxy Squid?

A pouco tempo eu tive um problema que julguei ser pontual, algo que poderia ser uma falha em meu squid.conf, mas depois de muito verificar, percebi que não há nenhum log de erro no cache.log, mesmo em debug 9.

Qualquer navegador que solicitasse a pagina support.microsoft.com só exibia uma tela branca, ou seja, a pagina está chegando com algum problema.

Sendo assim, em algumas pesquisas na internet, percebi que outras pessoas passavam pelo mesmo problema e logo a explicação “veio a tona”.

O problema está no fato que alguns servidores web retornam paginas com a codificação HTTP/1.1, porém o squid repassa a pagina com HTTP/1.0, assim gerando a pagina em branco no navegador. Dessa forma dificultando a minha analise, pois eu sempre verificava o tráfego.

Agora, a solução! A idéia é não aceitar a codificação proposta pelo web server. Claro que você pode apenas associar os sites problemáticos.

Vamos lá:

acl broken dstdomain ...
header_access Accept-Encoding deny broken

Pronto! Resolvido, pelo menos funcionou com o meu problema.

Fonte

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: